Table of Contents

1.0 About this guide . . . . . . . . . . . . 04
2.0 Introduction to RedPort Optimizer . . . . . . 05
3.0 Getting Started - Router Administration . . . . . . 06
4.0 RedPort Halo WiFi Extender . . . . . . . . . . . 08
5.0 GPS Tracking . . . . . . . . . . . . . . 13
6.0 GPS/NMEA Repeater . . . . . . . . . . . . . 15
7.0 Signal Monitor . . . . . . . . . . . . . . . 23
8.0 GSM . . . . . . . . . . . . . . . . 24
9.0 Restrict Wireless Network Access. . . . . . . . 29
10.0 Rename the Wireless Network. . . . . . . . . . . 31
11.0 Change Admin Password . . . . . . . . . . . . . 33
12.0 Update Firmware . . . . . . . . . . . . . . . 35
13.0 Access System Log . . . . . . . . . . . . . . 37
14.0 Reboot . . . . . . . . . . . . . . . . . 38
15.0 System Status for Monitoring Usage . . . . . . . . . 40
16.0 Profiles . . . . . . . . . . . . . . . . . 41
17.0 Firewall Modification . . . . . . . . . . . . . 43
Appendix A - Optimizer Quick Start Guide. . . . . . . . 46
Appendix B - Halo WiFi Extender Quick Start Guide . . . . 48
## Optimizer User’s Guide Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Revision</th>
<th>Author</th>
</tr>
</thead>
<tbody>
<tr>
<td>December 15, 2014</td>
<td>Initial Release</td>
<td>D. Brickhouse</td>
</tr>
<tr>
<td>March 19, 2015</td>
<td>Version 2.0</td>
<td>D. Brickhouse</td>
</tr>
</tbody>
</table>
1.0 About this guide

This guide is intended for onboard/onsite administrators of the RedPort Optimizer wXa-112 routers. It features only those sections of the user interface that require configuration for a specific service or may need to be accessed by the average user. For convenience, the Optimizer Quick Start Guide can be found in Appendix A of this document. It includes important information regarding the physical connection setup and initial configuration for email.

wXa refers to the webXaccelerator by RedPort, a trademark of Global Marine Networks, LLC.

The following chapter references will help you in administering the most-used features of the Optimizer.

Chapter 3.0  Getting Started
Chapter 4.0  Halo WiFi Extender
Chapter 5.0  GPS Tracking Service
Chapter 6.0  GPS/NMEA Repeater Settings
Chapter 7.0  Signal Monitor (how to change/disable)
Chapter 9.0  Restrict Wireless Network Access with password protection
Chapter 10.0 Rename the Wireless Hotspot Network
Chapter 11.0 Change the Router Admin Password
Chapter 12.0 Update Firmware
Chapter 13.0 Access Optimizer System Log
Chapter 14.0 Reboot the Router

Other useful information can be found in the following chapters:

Chapter 8.0  GSM Capability
Chapter 15.0 System Status for Monitoring Usage
Chapter 16.0 Profiles
Chapter 17.0 Firewall Modification
2.0 Introduction to RedPort Optimizer

Global Marine Networks (GMN), the leaders in advancing satellite data speeds and services, helps Fixed and Mobile Satellite Services providers and their customers by offering the industry’s fastest, most reliable and easy-to-use email, web, VoIP and other hardware and software services to maritime, oil and gas, first responder and business continuity users. The company’s products include XGate high-speed satellite email, WeatherNet weather and oceanographic data software, and vessel tracking systems.

Ship to shore network management solutions are sold by GMN under the RedPort Global brand name at www.redportglobal.com and as white-label solutions for the world’s premier satellite data service service providers.

Optimizer is a satellite firewall and WiFi hotspot router that lets you easily access accelerated satellite email, weather, web and tracking services, while blocking all unwanted data traffic.

*Email, Web, Weather and Tracking features require compatible service subscriptions.*

Key Features

Designed specifically for use with satellite phones and terminals:

- Compatible with any IP-based satellite phone and satellite broadband terminal.
- Powerful firewall stops all unwanted data traffic. Optimizer blocks all traffic except XGate-compressed email, web and weather data.
- WiFi signal makes setup and use with compatible computers and tablets easy.
- Works with XGate for email, web, weather and social media services.
- GSM support to switch between satellite and GSM when available.
- Track GPS locations from compatible GPS-enabled devices.
- Compatible with optional RedPort Halo WiFi Extender for access to external WiFi networks, when available.

*NOTE: The Optimizer ships pre-configured for use with XGate satellite email/data service. XGate service and Tracking service are not included with the Optimizer and must be purchased separately. Contact your satellite service provider for details.*
3.0 Getting Started – Router Administration

As the onboard/onsite administrator, under normal operating conditions, you will seldom have a need to interact with the user interface of the router. However, should you find yourself in a position that requires you to login to the router, this Guide is designed to help you.

**CAUTION: The Optimizer ships pre-configured for use with XGate satellite email/data service and the optional RedPort Halo WiFi Extender. Tampering with any settings that are not addressed in this Guide will violate the warranty and may render the Optimizer inoperable.**

Access the Optimizer User Interface

To access the Optimizer's user interface you must login to the router:

1. With power provided to the Optimizer, connect to the WiFi Hotspot created by the router using a desktop or laptop computer. Connect to the WiFi Hotspot just like you would any other WiFi connection:

   On a Windows PC, go to: Windows Start > Control Panel > Network Connections

   On a MAC, go to: Apple > System Preferences > Network

   The Network Name will look something like: ‘wxa-112-XXXX’ where ‘XXXX’ may represent the last four digits of the Optimizer Mac address. Select this wireless network.

2. Open any web browser on the computer and enter the URL: http://192.168.10.1

3. Login with the username = superadmin, password = webxaccess

   This login gives you full access to the user interface. If you do not require full access, there is an alternate login that provides limited access, restricted to use of the optional RedPort Halo WiFi Extender. Alternate login: username = admin, password = webxaccess
Once logged in, you will see the Optimizer's Home screen.

![Optimizer User Interface](image)

**NOTE:** The WiFi Extender Setup section only displays when the optional RedPort Halo WiFi Extender is physically connected to the Optimizer and powered ON.

**NOTE:** An alternate method to access the user interface: With power to the Optimizer, physically connect the Optimizer to your computer using a standard ethernet cable in the Optimizer's LAN port and follow the directions above, starting with Step 2, entering the URL http:192.168.10.1

Use the tabs to navigate through the user interface. You will see that the information represented in the user interface can be quite technical. This Guide will cover only those sections of the user interface that require configuration for a specific service or may need to be accessed by the average user.
4.0 Halo WiFi Extender

The Halo long-range WiFi extender system takes a weak WiFi signal – at a marina, for example, or truck stop, basecamp, etc – and amplifies that signal and routes it through the RedPort Optimizer WiFi hotspot. It has a marine enclosure designed for outside installation. Install the WiFi Extender almost anywhere outside.

For your convenience, the Halo WiFi Extender Quick Start Guide can be found in Appendix B of this document. It includes important information regarding the physical connection setup.

CAUTION: Attach the antenna to the Halo body BEFORE powering the unit. Powering the Halo without the antenna attached will damage the unit and may render it inoperable.

4.1 Configure Connection to the Halo

With the Halo powered ON and connected to the Optimizer. Login to the Optimizer router with either username = admin or with username = superadmin (see Section 3.0 Getting Started for details).

Configuration requires two steps to connect:

4.1.1 Step 1. Connect to the External WiFi Network

Select <Connect> button
Select <Scan> to see what wireless networks may be available.

Select the wireless network you want to connect to and press <Join Network>.

Enter the password to access the external wireless network, if required. Select <Submit>.

Notice the signal strength is 0% as you are not yet connected to the wireless network. Select <Save & Apply> to tell the Halo to connect to that network.
Notice that now the signal strength now registers greater than 0%.

**NOTE:** If the signal status is blinking from 0% to 100% this typically means that the WiFi Network Password/Key was entered incorrectly. Check with the external WiFi Network Administrator to confirm the correct password. Select the Wireless Security tab and enter the correct password in the Key field and <Save & Apply>.

Select the <Home> Tab to return to the Welcome screen.

### 4.1.2 Step 2. Route Network Traffic through the Halo

Select <Enable WiFi Extender>
All traffic is now routed through the WiFi Extender. You can run XGate and XWeb.

To return to routing traffic through your satellite device, simply select <Disable WiFi Extender>.

4.1.3 Step 3. Manage the Firewall (optional)

By default, the firewall is ENABLED. This means that ALL traffic from your computer is blocked from the internet with the exception of XGate and XWeb traffic. This setting is recommended when using the Halo in areas where there may be many users competing for the wireless network bandwidth thereby causing slow and painful internet connections.

If you want to sync some applications or perform some other function that is currently being blocked, i.e. streaming video, you must Disable the Firewall.

To Disable the firewall:

Select <Disable Firewall>
Your computer now has full access to the internet for syncing applications, browsing, etc.

To turn the Firewall back on, select <Enable Firewall>

### 4.2 Disconnect from the Halo

To disconnect from the Halo select <Disable WiFi Extender>

<table>
<thead>
<tr>
<th>Step 1</th>
<th><img src="connect.png" alt="Connect" /></th>
<th>Select external WiFi network to connect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td><img src="enable.png" alt="Enable WiFi Extender" /></td>
<td>Route traffic through Satellite Link.</td>
</tr>
<tr>
<td>Step 3</td>
<td><img src="disable.png" alt="Disable Firewall" /></td>
<td>Firewall Status: <strong>ON</strong></td>
</tr>
</tbody>
</table>

Notice that the Firewall is turned back on automatically to protect you from runaway airtime charges.

**NOTE:** An alternate method of disconnecting from the Halo is to cycle power to Optimizer or Reboot the Optimizer. This will also restore the Firewall Status to ON.

**CAUTION:** It is important to <Disable WiFi Extender> when the external WiFi network is no longer available and you want to use your satellite device. Failure to Disable will prevent a successful satellite connection as the Optimizer continues to look for the external WiFi network.
5.0 GPS Tracking

If you wish to have tracking service using your satellite device, the Optimizer offers GPS Tracking service powered by GSatTrack or Tracking service via SMS message.

5.1 Tracking powered by GSatTrack

Using a GPS-enabled satellite device, the Optimizer can be configured to submit position reports to a central database for viewing on the tracking website.

This tracking service must be purchased separately. See your satellite service provider for details.

To enable this service, select Services > GPS Tracking > Tracking.

![Tracking Parameters](image_url)
Step 1. Enter the **Tracking Interval** in minutes; the default is set to hourly reporting (60 minutes). This means that every 60 minutes a position report will be transmitted over your satellite link. Keep in mind that standard airtime charges will apply to each position report. Adjust the Tracking Interval to meet your needs.

Step 2. Select the satellite terminal you are using. Note: a valid NMEA/GPS feed is required when using some satellite devices.

Step 3. Select <Save & Apply>.

### 5.2 Tracking via SMS

If using certain satellite devices, GPS information can be sent to an email address using your satellite provider's SMS service. Standard SMS charges may apply; check with your satellite airtime provider for details.
Step 1. Enter the **Tracking Interval** in minutes; the default is set to hourly reporting (60 minutes). This means that every 60 minutes a position report will be transmitted via the SMS service provided by your satellite provider network. Keep in mind that standard SMS charges may apply to each position report. Adjust the Tracking Interval to meet your needs.

Step 2. Select which satellite device you are using. At this time, tracking via SMS is available with the Inmarsat IsatPhone, Iridium handheld 9575 Extreme, Iridium GO! or an Iridium terminal such as the Pilot. Note: a valid NMEA/GPS feed is required when using an Iridium terminal.

Step 3. Enter the recipient's email address. The SMS message with the GPS information will be sent to this email address at the interval entered in Step 1.

Step 4. Select <Save & Apply>.
6.0 GPS/NMEA Repeater

The Optimizer supports USB and RS-232 NMEA devices allowing multiple applications to share the GPS/NMEA data. If you have a NMEA RS-422 device, adding a RS-422 to RS-232 converter to your setup may allow the sharing of data.

The Optimizer does not transmit data but can be configured to receive and repeat GPS/NMEA data from:

- A broadband satellite terminal with integrated GPS when connected to the Optimizer via a standard ethernet connection. (As of this writing, supported terminals include: Iridium Pilot, Inmarsat FBB and Inmarsat BGAN).

- A handheld satellite phone with integrated GPS when connected to the Optimizer with the satphone's USB-Mini/Micro USB cable. (As of this writing, supported handheld satphones include: Iridium 9575 Extreme and Inmarsat IsatPhonePro.)

WARNING: IsatPhonePro users! The phone only transmits GPS coordinates about every 10 minutes. It is NOT recommended for navigation or any application that requires real time data.

- A USB connected GPS or NMEA device.

- A serial port connected GPS or NMEA device

NOTE: If you are using a satellite phone with a serial port (RS-232) that transmits GPS data (i.e. some fixed phones and fleet phones), it is NOT compatible with the Optimizer. In order to repeat GPS data, a separate GPS device must be connected.
6.1 Equipment Setup

A physical connection is required from the source (satellite terminal or satellite phone that transmits GPS coordinates, or other GPS/NMEA device) to the Optimizer.

6.1.1 Broadband Satellite Terminal with Integrated GPS

When using a supported broadband satellite terminal with integrated GPS, connect the terminal to the Optimizer SAT port using a standard ethernet cable.

(OPTIONAL: Use a second ethernet cable to connect the computer with the destination software, like a navigation program, to the Optimizer LAN port.)

The Optimizer will broadcast the GPS signal both over Ethernet and WiFi, so you can connect your computer either way in order to establish a successful connection with your destination software.
6.1.2 Handheld Satellite Phone with Integrated GPS

When using a supported USB connected satphone with integrated GPS, connect the satphone to the Optimizer using the Mini-USB (satphone) to USB (Optimizer) cable.

(OPTIONAL: Use an ethernet cable to connect the computer with the destination software, like a navigation program, to the Optimizer LAN port.)

The Optimizer will broadcast the GPS signal both over Ethernet and WiFi, so you can connect your computer either way in order to establish a successful connection with your destination software.
6.1.3 USB NMEA Device

When using a NMEA device that supports a USB connection, connect the GPS/NMEA device to the Optimizer with an appropriate USB to NMEA device cable as indicated by the NMEA device manufacturer.

(OPTIONAL: Use an ethernet cable to connect the computer with the destination software, like a navigation program, to the Optimizer LAN port.)

The Optimizer will broadcast the GPS signal both over Ethernet and WiFi, so you can connect your computer either way in order to establish a successful connection with your destination software.

NOTE: If your satellite device requires a USB connection to the Optimizer (for example, an Iridium 9555) you can use a 2-port USB hub (either 1.0 or 2.0) plugged into the Optimizer's USB port to accommodate two USB devices.
6.1.4 RS-232 NMEA Device

With Serial Port Connector

When using a NMEA device with Serial Port connection, a USB to Serial Adapter (PL-2303HX) is required to connect the device to the Optimizer.

**CAUTION: The PL-2303HX is the only USB to Serial Adapter that is compatible with the Optimizer.**

The Optimizer will broadcast the GPS signal both over Ethernet and WiFi, so you can connect your computer either way in order to establish a successful connection with your destination software.

**NOTE:** If your satellite device requires a USB connection to the Optimizer (for example, an Iridium 9555) you can use a 2-port USB hub (either 1.0 or 2.0) plugged into the Optimizer's USB port to accommodate two USB devices.
Without Serial Port Connector

Some NMEA devices do not have a serial port; instead they have a group of wires extending from the back or bottom of the unit. These devices require proper wiring to a serial port.

As the Optimizer does not transmit, it only repeats the data, you will only need two of the wires. The Receive (RD) wire goes to pin 2 and the Ground (SG) wire goes to pin 5.

A simple solution is to use a terminal block as shown here. Simply connect the RD wire to pin 2 and the SG wire to pin 5. Then connect the terminal block to the PL-2302HX USB to serial adapter as noted above.

6.1.5 Connecting Multiple NMEA Devices

It is possible to connect up to four NMEA devices if you have the proper hardware. It will require a USB to RS-232 4-port Hub or a RS-232 4-port terminal block that you would simply plug into the Optimizer’s USB port.

NOTE: The Optimizer supports RS232. If you have a NMEA RS-422 device, adding a properly wired RS-422 to RS-232 converter to your setup may allow the sharing of data.
6.2 GPS/NMEA Repeater Parameters Configuration

In order for the destination software to properly route the GPS data you must configure the GPS/NMEA Repeater Parameters in the Optimizer User Interface.

From the Optimizer Home page select Services > GPS/NMEA Repeater tab.

![Optimizer User Interface](image)

Step 1. Select the source of the GPS/NMEA information (choose only one):

- **GPS from broadband satellite**: Select this if you are using a broadband satellite terminal with integrated GPS.

- **GPS/NMEA feed from USB**: Select this when connecting a GPS or NMEA device via USB cable.

Step 2. **NMEA Baud Rate** - Using the drop down menu, select the baud rate required for the destination software. By default, most NMEA 183 devices (GPS) and applications use 4800 baud for this setting.

Step 3. **UDP Listener Port** - Enter the UDP port number that the GPS is connected to. The default is set to the standard UDP Listener Port for NMEA 183 devices of 10101.
Step 4. **UDP Port** - Enter the UDP port number to broadcast the GPS data to. The default is set to the standard UDP Port for NMEA 183 devices of 11101. (Note: configure the destination software to match this port number; or, change this entry to match the requirements of the destination software.)

Step 5. **TCP Port** - Enter the TCP port number to broadcast the GPS data to. The default is set to the standard TCP Port for NMEA 183 devices of 11102. (Note: configure the destination software to match this port number; or, change this entry to match the requirements of the destination software.)

---

**NOTE:** The data will be broadcast to both the UDP Port and the TCP Port. **It is important to make sure that these two ports are NOT set to the same port number.**

---

To use the GPS Repeater feature, your computer must be connected to the Optimizer’s WiFi network or directly connected to the LAN port of the Optimizer.
7.0 Signal Monitor

Signal monitor queries your satellite device to determine if the signal strength is sufficient to make a successful data connection. Typically, a minimum of 60% signal is required; however, 100% is ideal for the fastest possible data transfer rate.

**NOTE:** Some of the older satellite phones (for example, the Iridium 9505a) do not support the signal monitor feature. For these older satellite phones, the signal monitor MUST be DISABLED for a successful data connection.

To modify the Signal Monitor, go to: Services > PPP > Settings.

From this screen you can enable/disable signal monitor using the "Enable" checkbox.

You can change the level of the Signal Monitor. Keep in mind that 60% is typically the minimum required for a successful data connection. If you must change the Signal Monitor, we recommend lowering the Level vs. disabling it. Many IsatPhonePro users have had success by lowering the level to 40 or 30.

**CAUTION:** Reducing the signal strength to less than 60% or disabling it altogether may cause lengthy data connections due to poor signal.

When you are done making changes, click <Save & Apply>.

Signal monitor can also be changed from within the XGate Settings. See the XGate Help File > User Interface > Settings > Optimizer, wXa, & Sat-Fi for details.
8.0 GSM

The GSM feature is offered for your convenience but we are not able to support it. The information provided here is general in nature but may not be sufficient to establish a GSM connection. If you run into any difficulties you must contact your GSM network provider for support.

If you have a GSM-based cellular phone, it may be possible to use the GSM network, when available, for XGate and XWeb data over the Optimizer. You will get the benefits of compression and a faster data transfer rate than over a satellite phone which typically equates to cost savings.

Only GSM-based service is supported. LTE-based and CDMA-based service is NOT supported. If you are unsure of which service you have, contact your cellular provider before attempting to configure for GSM connection.

8.1 GSM Configuration in Optimizer

Before you can configure the Optimizer for GSM, you must:

- Obtain a USB data dongle from your cellular provider. Your provider may also require you to purchase a data plan.
- Activate the USB data dongle with your cellular carrier and test it to make sure it works. Typically, testing requires only that you plug the USB Data Dongle into your computer and see if you can get on the Internet. If testing fails, contact your cellular carrier for support.
- Contact your cellular provider to obtain the information required to connect to their GSM network. The information may include:
  - Access Point Name (APN)
  - Username required for access to the APN
  - Password required for access to the APN
To configure the Optimizer for GSM service.

Login to the Optimizer and go to: Services > PPP > Settings > GSM.

Step 1. Enter the Access Point Name (APN) as provided to you by your cellular carrier.

Step 2. If you have protected your cellular SIM card with a pincode, enter the pincode here.

Step 3. Click <Save & Apply>

NOTE: As of this writing, some customers have found the APN Wizard helpful in lieu of entering the information manually; however, it is still under development and may or may not help with your configuration.

Now go to: Services > PPP > Settings > PPP
Step 4. Enter the username required for access to the APN, if any.

Step 5. Enter the password required for access to the APN, if any.

Step 6. Click <Save & Apply>
8.2 Using GSM

When you want to use GSM service instead of satellite service:

Plug the USB data dongle you obtained from your cellular provider into the Optimizer's USB port.

**IMPORTANT:** If your satellite terminal is connected to the Optimizer's SAT port, unplug the cable from the SAT port before attempting a GSM connection.

Configure XGate Settings for GSM connection. Open XGate to Settings > Connection>

Select the Connection Type <Optimizer GSM>. Click <OK> to apply the change.
8.3 Changing from GSM service to satellite service

When you travel beyond GSM range you must:

- Remove the GSM data dongle from the Optimizer's USB port.
- Connect your satellite phone/terminal to the Optimizer (either via USB port or SAT port).
- Change the XGate > Settings > Connection Type back to the appropriate Optimizer setting.

**NOTE:** There is no need to change anything in the Optimizer user interface.

---

*IMPORTANT*: We are not able to support the GSM feature. If you experience any connection difficulties when using this feature, you must contact your GSM network provider for support.
9.0 Restrict Wireless Network Access

When in public locations, for example, a crowded marina or anchorage, you may want to restrict access to your WiFi hotspot created by your satellite device and the Optimizer. You can password protect your WiFi hotspot so others cannot use it.

The easiest way to add password protection to your WiFi hotspot is to modify the XGate Settings. See the XGate Help File > User Interface > Settings > Optimizer, wXa, & Sat-Fi for details.

As an alternative you can add password protection to the WiFi hotspot via the Optimizer user interface.

**Add/change a password to the WiFi Hotspot (wxa-112-xxxx)**

Login to the Optimizer:

Select <WiFi Setup> and go to: Interface Configuration > Wireless Security
Step 1. Select the Encryption mode from the drop down menu. We suggest WPA-PSK/WPA2-PSK Mixed Mode.

Step 2. Enter your desired password in the Key field.

Step 3. Click <Save & Apply>

This procedure adds/changes the password for the WiFi hotspot only. When connecting your computer, iOS or Android device to the wireless network, this is the password you will use. This password does not change the router superadmin or admin password when logging in to access the Optimizer user interface.
10.0 Rename the Wireless Network

It is possible to change the name of your wireless network. This is the name of the wireless network that you connect to using your computer or iOS or Android device. The default name is wXa-112-xxxx where the xxxx represents a unique number.

The easiest way to change the wireless network (WiFi hotspot) name is to modify the XGate Settings. See the XGate Help File > User Interface > Settings > Optimizer, wXa, & Sat-Fi for details.

As an alternative you can change the name of the wireless network (WiFi hotspot) via the Optimizer user interface.

To change the name, login to the Optimizer:

Select <WiFi Setup> and go to: Interface Configuration > General Setup
Step 1. Enter the new wireless network name in ESSID field.

Step 2. Click <Save & Apply>

This procedure changes the name for the WiFi hotspot only. When connecting your computer, iOS or Android device to the wireless network, this is the network name that will appear in the wireless network list. This name does not change the router superadmin or admin name when logging in to access the Optimizer user interface.
11.0 Change Superadmin and/or Admin Password

The default password for both the superadmin login and the admin login is set to: webxaccess.

The easiest way to change the login admin password is to modify the XGate Settings. See the XGate Help File > User Interface > Settings > Optimizer, wXa, & Sat-Fi for details. The only way to change the superadmin password is via the Optimizer User Interface.

To change the password(s), login to the Optimizer:

Select <Router Password>
When logged in as the superadmin, you will see this screen. If logged in as the admin user, you can only change the password for the admin login.

Step 1. Enter the new password in the password text box.

Step 2. Enter the same password again in the Confirmation text box.

Step 3. Click <Save & Apply>

This procedure changes the password for the Superadmin or the Admin login only. When connecting your computer, iOS or Android device to the wireless network, you will not use this Admin login password. This password is used only to access the Optimizer user interface.
12.0 Update Optimizer Firmware

Get the latest Optimizer firmware version from here: http://www.redportglobal.com/support/technical-downloads/

Save the .bin file to your computer (pc or mac)

**NOTE:** If you have created any Profiles you may want to Export them before flashing new firmware and Import them when done. See Chapter 16 for Profiles details.

Login to the Optimizer and go to: System > Backup/Flash Firmware

Step 1. Keep Settings: remove the check in the box to uncheck Keep Settings.
Step 2. <Browse> to where you saved the .bin file and select that file.

Step 3. Select <Flash Image>

Step 4. Wait for the grey button on top of the Optimizer to begin flashing. When the button stops flashing, the firmware is done updating. This typically takes several minutes.

To confirm the firmware upgrade, login to the Optimizer Home Page again. The firmware version displays in the top banner of the User Interface.
13.0 Access System Log

If you are experiencing connection issues your service provider may request that you send them a copy of the Optimizer System Log.

Step 1. Attempt an email connection
Step 2. Login to the Optimizer Home page
Step 3. Go to Status > System Log

Step 4. Copy/paste the entire log into an email and send to your service provider.

Note: The System Log date will show May 31 unless you have synced the Optimizer Local Time with a browser in System Tab > Local Time > Sync with browser. This is NOT recommended when using a satellite connection and it is not necessary to ever sync the time. If you do sync the time, as soon as power is removed from the Optimizer the date will revert to May 31.
14.0 Reboot the Optimizer Router

The easiest way to reboot the Optimizer is to use the reset button on the bottom of the router. Using a pointed instrument, press and hold the red reset button for 20-30 seconds and release. Wait for the Optimizer reboot, this will take several minutes. After this reset, the Optimizer will be configured with its factory defaults. You will need to re-enter any modifications you made to the user interface.

You can also reboot the router from within the Optimizer user interface:

Step 1. Login to the Optimizer Home page

Step 2. Select <Reboot Router>
Step 3. Select <Perform reboot>

The grey button on top of the Optimizer will flash during the reboot process. When the light stops flashing the reboot is complete. This will take several minutes.

*During the reboot process you will lose access to the Optimizer User Interface. You must login again if you want access. (See Chapter 3.0 Getting Started)*
15.0 System Status for Monitoring Usage

For those that are interested, you can view the connection status in Status > Realtime Graphs
16.0 Profiles

Profiles is designed for users of multiple satellite devices and integrators of custom installations. You can configure the Optimizer for a specific satellite device and save the profile. This is good for failover situations when using multiple devices. An extreme example would be that you might have the firewall wide open on a VSAT device but in an emergency must use an Iridium handheld device where you want the full protection of the Optimizer firewall. Have a profile for each configuration and select the appropriate one for the satellite device being used.

To access Profile Manager, go to System > Profiles

![Profile Manager](image)

There are two default profiles:

AccessPoint: This profile is used when linking two or more Optimizers together to extend the satellite WiFi hotspot range. Using an ethernet connection between two Optimizers with only one Optimizer connected to the satellite device, select this AccessPoint Profile on each Optimizer that is NOT connected to the satellite device.

Factory: This profile will reset the Optimizer to factory defaults and all custom configuration will be lost.
To create and use a new Profile:

Step 1. Select <Add>
Step 2. Enter a Name of the new profile and a description.
Step 3. Select <Install> to add the new profile.
Step 4. Select <Save & Apply>.

To change from using one profile to another, simply select <Install> for the desire profile, then <Save & Apply>
17.0 Firewall Modification

By default, the Optimizer ships with a powerful firewall configured to block ALL inbound or outbound traffic except XGate email, web and weather. This configuration protects you from experiencing runaway satellite airtime bills.

If you have a need to open the firewall, go to: Network > Firewall > Traffic Rules

These are the firewall rules that protect you. There are six rules that are not 'enabled' (i.e. the check box is empty). Checking these rules will open the firewall to all traffic; but, you lose the benefit of XGate compression.

![Firewall - Traffic Rules](image)

**IMPORTANT NOTE:** Modifying the firewall is neither an intended nor a supported use of the Optimizer. Modifying the behavior of the Optimizer firewall other than the above will void the warranty and may render the Optimizer inoperable.
This concludes the RedPort Optimizer User Guide. If you have a question that is not addressed in this Guide or if you have recommendations to improve the usefulness of this Guide, please contact us at: support@gmn-usa.com
Physical Setup

1. Connect the satellite phone or terminal to Optimizer
   - USB port for satellite handsets. (Note: A USB to serial adapter is required for RS232 based satellite phones such as the Iridium 9505(a).
   - Ethernet for satellite broadband devices (OpenPort, BGAN/ FleetBroadband)

2. Connect the power
   12V DC required. Use supplied AC Adapter, or optional battery or adapters.

3. Connect your computer
   - Via an Ethernet cable, or:
   - Via Wi-Fi

4. Install XGate and/or set up GPS Tracking services
   See back page for setup details.

XGate Installation and Setup

XGate is the world’s leading independent satellite email, web and weather service. Optimizer blocks all traffic except XGate-compressed email, web and weather data. After completing the physical connection:

1. Download the XGate software
   iOS (iPad, iPhone, iPod Touch) Search for “XGate” in the iTunes store (http://itunes.apple.com or in the iTunes Store App.)
   Android (any Android device 2.3 or higher) Search for “XGate” in the Google Play Store (https://play.google.com or in the Google Play Store App)

2. Connect your satellite terminal, powered on with a good signal, to Optimizer.

3. Install and Run XGate
   - A registration wizard appears the first time you open XGate. Select the registration method (Activation code, 3 day demo, etc) and click “Next”

4. Select "webXaccelerator/Optimizer" for the connection type.

5. Select your satellite terminal type and complete the registration wizard.
   - Iridium - "webXacc Iridium Direct Internet"
   - Isatphone - "webXacc IsatPhone Pro"
   - Globalstar - “webXacc Globalstar”
   - Fleet Broadband - “Network Connection” (Unmanaged Connection)
   - Iridium Pilot/OpenPort - "webXacc Iridium OpenPort"
   - BGAN - “Network Connection” (Unmanaged Connection)
   - Thuraya - “webXacc Thuraya”

GPS Tracking

Optimizer works as a tracking device with the industry-leading RedPort Tracking service. Optimizer provides tracking data using the GPS chip built into many satellite terminals. For more information, visit http://tracking.redportglobal.com

Optional Equipment

- 12V External battery power supply
- 12V external cigarette lighter adapter
- High gain 5db antenna
- USB-Serial adapter
Iridium Pilot / OpenPort Settings

Optimizer supports both managed and unmanaged connections for Iridium Pilot/OpenPort.

**Managed connections** are highly preferable for most Pilot/OpenPort installations with an Optimizer. Optimizer will keep the connection alive by issuing pings to a remote host every 5 seconds while either an email or web session is in progress. Otherwise the Iridium OpenPort will shut down the connection after 20 seconds causing the user to wait 20-30 seconds on the next network activity while the session is restarted. This connection delay can make it difficult to browse since the browsers will often encounter timeouts and wait times while the connection is being reestablished.

- **Pilot/OpenPort users should set the XGate connection type to "webXacc Iridium OpenPort" for managed connections.**

**Unmanaged connections** are selected when the connection type is set to “IridiumOpenPort”.

Iridium Pilot/OpenPort does not have a minimum billing increment so airtime fees for managed/unmanaged connections are the same.

Advanced Settings

**Port Definitions**

- **LAN** is configured as the LAN port with IP address 192.168.10.1.
- **WAN** is configured with DHCP and should be connected to your primary satellite unit.
- **USB** should be connected to the USB port on handheld satellite phones such as Iridium, IsatPhone, Thuraya, or Globalstar.
- **WLAN** is configured as the WiFi port (on units with WiFi) with IP address 192.168.20.1.

**Optimizer “Push-to-Connect”**

You can configure Optimizer to make a data connection automatically when you push the gray button on the top of Optimizer. Log in to Optimizer’s UI and go to Services > USB Phone > Settings > Network and select your satellite phone or GSM dongle. Now the gray button on Optimizer will connect/disconnect you from the internet when you push it.

Pushing the button will cause the button to blink while your phone/GSM dongle is connecting. Once connected the button will go solid.

Pushing the button again will cause the button to blink until the device disconnects.

The user can change the firewall manually under network->firewall->rules to allow 3rd parties to use the Optimizer for satellite communication without requiring software.

Inmarsat BGAN / FleetBroadband Settings

Optimizer supports both managed and unmanaged connections for Inmarsat broadband users.

**Managed connections** are intended for satellite terminals configured to be offline except when a data session is taking place.

Select the device name during the registration wizard process outlined under Software Installation, or under the connection type in options > settings > connection (preferences > connection on the mac).

Configure your terminal for "manual" connection mode.

When using XGate the software will instruct the terminal to go online, send/receive (or browse), and then close down the connection. Note that an Inmarsat minimum airtime billing increment will be incurred for every connection.

**Unmanaged connections** are intended for satellite terminals configured to be online all the time. To use this method configure your terminal to automatically connect to the Internet on network traffic. In XGate set the connection type to "Network Connection" in options > settings (preferences > connection on mac).

Note that since Optimizer blocks all traffic except email and web unmanaged connections you will experience lower airtime bills since the number of connections incurring minimum billing increments is reduced.

**Hybrid (Not Available on iOS or Android)**

Setting the XGate connection type to the Inmarsat terminal and checking the option "Use another connection if already open" causes XGate to use an active Internet connection if available. If none is available, then XGate will manage the connection.

**Optimizer Administrative Page**

The Optimizer administrative page may be accessed to set up tracking, or access detailed router logs, advanced firewall settings, and firmware upgrades.

IP: 192.168.10.1

Use a web browser and URL [http://192.168.10.1](http://192.168.10.1) on the LAN port or via WiFi.

user: admin
password: webxaccess
RedPort
Halo Long Range WiFi Extender

Quickstart Guide
and Setup Manual
1. Attach antenna to extender.

**Important!**
You must attach the antenna to the extender FIRST before connecting anything else. Failing to do so may short your equipment.

2. Run the Ethernet cable through the opening on the metal base.

3. Put the o-ring around the bottom part of the middle threaded connector.

4. Run the Ethernet cable through the pieces as shown.

5. Push gray plastic gasket into the hole. Will not create watertight seal (add silicon if you wish).
Plug in the Ethernet cable into the Ethernet port on the base of the extender.

Screw together all components, careful to not thread the extender connectors.

Then screw in small connector screws into metal base using provided alan wrench.

Plug Y-cable into either provided 110-220V AC adapter or optional 12V “Cigarette Plug” adapter (sold separately).

Plug WiFi Extender Ethernet cable into Optimizer LAN Port.

Take the Y-cable provided and connect one barrel connector into the Optimizer power port.

Plug the other barrel connector into the power cable for the WiFi Extender.
Configuring Optimizer to Use the WiFi Extender

Step 1
WiFi-connect to the Optimizer.

Step 2
Use a web-browser to go to this URL: 192.168.10.1
Optimizer’s login screen will appear.

Step 3
Login with the following information:

Username: admin
Password: webxaccess

The WiFi Extender Setup section of the Optimizer home page should be visible. (This section only appears if the Extender is plugged into the LAN port of the Optimizer and the Extender is powered on. If either of those conditions is not met, then this section will not be visible in the Optimizer interface).

Step 4
Connect to the external WiFi network by clicking on the <Connect> button.

Step 5
You are now in the “Wireless Overview” tab. You need to scan for available WiFi networks in order to connect.

Hit <Scan>

Select the WiFi network you want to connect to and press <Join Network>

Step 6
Enter in the password for the WiFi network (if required)

Hit <Submit>

Step 7
Select <Save & Apply> to confirm that you want to connect to that WiFi network. Until you are connected, the signal strength will say 0%.

Click on the Home tab to go back to the Home screen.
Routing Network Traffic

Because Optimizer can be used to connect to a number of different networks (like satellite, for example) you need to tell it to route traffic through the WiFi Extender.

On the Wireless Overview page select: <Enable WiFi Extender>

(You may be asked to re-enter your username and password. Reference these under Step 2).

All traffic is now routed through the WiFi Extender.

If you want to stop using the WiFi Extender (say, if you want to route traffic through your satellite device again), simply select <Disable WiFi Extender>

Managing the Firewall

By default, the firewall is enabled. This means that all traffic from your computer or mobile device is blocked from the Internet except for RedPort compression software.

(Optimizer-compatible compression services include XGate and XWeb, OCENS Mail, Satphone.me, and many more. See www.redportglobal.com for a full list of compatible compression data services).

This setting is recommended when using the WiFi Extender in areas where there may be many users competing for the WiFi network bandwidth thereby causing slow and painful internet connections.

If you want full access to the Internet (for example, for syncing a program or accessing services or apps that are being blocked (ie: streaming video), you must disable the firewall.

To disable the firewall, hit <Disable Firewall>

To disconnect from the WiFi Extender, select <Disable WiFi Extender>

Once disabled, the Firewall will turn back on automatically. If Optimizer is powered on and off, the Firewall will come back on automatically.
Troubleshooting

If you are unable to establish a connection to the long distance WiFi, please send an email to the technical support department of the dealer from whom you purchased the Halo equipment. Please include the following information:

1. Are there lights on for both Optimizer and the WiFi Extender?

2. Is the Ethernet cable from the WiFi Extender plugged into the LAN port of the Optimizer?

3. When you access the Optimizer interface, do you see a section called “WiFi Extender Setup?”

4. When you look at the available networks, please tell us how much signal strength Optimizer has (should be identified as wxa-XXXX).

Please note that you are using the RedPort Halo WiFi Extender system and submit your answers in an email to your dealer.